
Basic User guide to Navigation, Filtering and Reporting

To make use of these notes you will require a basic licence for frontend4business. 
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Overview

This overview gives an introduction to f4b, explains the basics of its use and introduces some 
f4b concepts.

What is f4b?

f4b is a Rapid Application Development tool that gives you the ability to analyse, edit, sort, 
filter and report on any data held within your database. It allows you to extract detailed 
information in any combination that is meaningful and relevant to you. 

f4b groups views of your database tables onto a tabbed form, each tab being a view. These 
groupings are called ‘Activities’ within f4b. For example, jobs may have associated deliveries, 
sales and purchase invoice information that would be on their own tabs, the whole set of tabs 
would be saved as an activity.

Having used the filtering tools provided on an existing view the resultant view can be saved as 
a favourite view. This allows you to quickly reproduce your analysis as a report and/or input 
default values in your database.

Saved views and activities can be emailed directly or via the built in scheduler as management
reports or key performance indicators for customers, these can be as .pdf documents or 
spreadsheets etc.

Querying the database 

For a typical query, you might go through the following process. 

1. Choose an activity, for example, purchase invoices.

2. Filter the data

3. Manipulate the display

4. Save your query as a view

5. Create a report

About the available data

The system administrator will have defined what data, that is which activities and views within 
your f4b application, are available to you. You will most likely have access to a subset of the 
whole database. 

For speed f4b provides the option of caching data. This is usually significant where a view 
requires summing of detail data for presentation with header information (we term these Roll 
Up Views). How often such cached data is updated depends on whether your data entry is 
done via f4b or an external application. f4b applications will generally maintain the cache in 
real time while data entered via an external application will be updated at a period set within 
f4bs scheduler.   
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f4b terminology 

Below is a glossary of terms and concepts used in f4b and within this guide.

View A table of data shown on a tab

Activity A set of related views of your database. There may be one or more 
activities available to you

Favourite 
View

A favourite view relates to the tab you are on, generally it is a 
filtered version of the initial table presented that you have saved to 
use again. You can save any number of favourite views for each 
tab. The list of favourites is presented at the bottom of the File 
menu and changes when you change tabs.

Cache From an f4b perspective the Cache consists of a table or tables 
which hold the result of running a Roll Up Query/Views, an example
would be all the Customer account totals for the last 10 years. 
Since previous year results are unlikely to change often f4b 
identifies only the records that have changed and keeps them 
updated. 

Filter A filter allows you to include or exclude specific data rows from your
view.

View Style View data can be viewed either in a tabular style, much like a 
spreadsheet or as a WYSIWYG report in a report viewer
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Getting Started

Accessing f4b

 Generally you will have a shortcut on your desktop, double click. 

Enter a valid user name and password and you will be taken to your Default Activity as set up 
by the administrator. 

It is possible to pass start-up parameters to f4b from a shortcut. This means that other apps 
can fire off f4b passing the User name and Password resulting in this screen being bypassed.
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Your home screen/activity

Your home screen will look similar to the one shown below. The home screen displays your 

default activity with all its data. You can return to this at any time with the Home key .

No Description Functionality

1 Title Bar Shows your user id and information related to the current query such 
as number of pages and total number of records (record count).

2 Command 
Menu

Provides access to f4b functions.

3 f4b Toolbar Icons give access to the most common functions within f4b. All of the 
functions available here are also available through the Command 
menu.

Refer to the section on The f4b toolbar.

4 Tab List A set of tabs generally describes a workflow or dataset that f4b terms
an Activity. Tabs may be formally linked in that filtering on one tab 
effects the data retrieved when moving to a linked tab. 

5 Filter Status 
Icon

Tabs that have filters set display a filter icon on the tab label. 

 means a filter is set on this tab, the filtering is unaffected by 
filtering on other tabs. This is often denotes a primary/header tab.

 means a filter is set on a primary tab that affects the data 
retrieved, this is a linked tab and may display some primary tab data.

 means a filter is set on a primary tab that affects the data 
retrieved, additional filtering has been added while viewing this tab, 
this is a linked tab.

By moving your mouse over the tab label f4b will display the filter as 
a tooltip without you needing to move to the tab.
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6 Management 
Reporting 
Tabs

This group of tabs provide aggregate (sum,avg etc) summary analysis
of data on primary tabs. These are linked tabs. Currently four types of
analysis are available.

League: allows you to group by one field and aggregate the numeric 
fields. Charting with Pies etc.

BreakDown: allows you to group by any number of fields and 
aggregate the numeric fields. An additional type of report view with 
drilldown is available on these tabs.

Period Comparisons: allows comparison and changes of numeric 
values over 2 selectable time periods for a selected grouping. 
Charting with bar charts etc.

OverView: This is a basic cross-tabulation (simplest form of pivot 
table), two grouping fields are selected along with a single numeric 
field. Charting with Stacked bars etc.

7 Filter line Entering info into this line results in the main data being filtered

8 Column 
Heading

Identifies the fields within the data record.

9 Main Data Grid the area that displays the data returned by your view. The records 
may be long and there may be many of them. Use the scroll bars on 
the bottom and right hand side to move through the data.

10 Record 
Selector

can be used to select one (often for editing via a form) or a group of 
lines in the main grid, maybe for a simple copy and paste

11 Totals Line This line totals/sums your numeric data. The values presented are the
sum of all pages not just the one that is being displayed. If you have 
the privileges this can be switched on and off via the main toolbar.
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Navigation

Selecting an activity
To select and view an activity:

1. Go to File> to display the activities available to you. The activities available to you are 
arranged at the top of the file menu and are arranged in sub menu groups depending on 
what User Groups you are a member of, generally the main menu item will be the name of 
a database. The first item on the menu, ‘Activities’ may also have a sub menu, the sub 
menu will then provide a list of Activities that are restricted to your personal use. 

Using a favourite view

At the bottom of the file menu are your favourite views for the current tab/form (the form 
name is shown on the title bar). The colour coding will explain the conditional formatting being 
seen on the main grid.

Generally selecting a favourite view loads the grid with a pre-filtered view of the main data for 
this form. 
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Creating a new view

You can create a new view by setting filters, selecting columns, setting column widths and a 
sort order on the data in the main grid. 

Setting a filter
1. Basic filtering. Typing into a cell of the filter column results in f4b performing a search of 

the data in that field/column, the search is automatically run when you stop typing (the 
speed at which f4b decides you have stopped typing can be individually adjusted by your 
administrator). 

Here we are looking for jobs where the Department begins with ‘S’ and Country begins 
with ‘I’ and Year = 2012.

Starting a filter cell with = < > or * changes the way that f4b filters. An intuitive way of 
finding data in character fields is to type the first few letters which returns records that begin 
with your typed letters, then double clicking on a cell in the main grid resets the filter to be = 
the cell value.  

Clicking the toolbar button ‘Clear Filter’  on the Jobs tab, a primary tab, will also clear the 
filters on the other linked tabs.

To clear the filtering on all the tabs click either the toolbar buttons ‘Home’ or ‘Hotel’

2. Negating a filter.
 

Here we are filtering for all the jobs where Country does not start with ‘I’. To do this select 
the filter cell you want to negate and press the ‘Not’ button on the toolbar. 

3. Filtering for empty fields. Double clicking a blank field in the main grid sets the filter for the
current column to ‘Empty’, the records returned will be both NULLs and zero length strings.
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4. Filtering for dates. You can type a date directly into a filter cell, double click on a date field 
in the main data grid, choose from a range of common date filters or set a date range..

The filter menu offers you a range of common 
date filters

Selecting a Date Range

5. Global filtering. A classic problem when filtering address data is that city and ZIP code data
has been entered into the wrong columns. f4b provides a quick method of finding the 
records required. 

Simply enter your filter string into the global search box of the toolbar, press Enter or .

6. Advanced filtering. 
You can build more sophisticated filters by using the Custom Filter dialog from the toolbar.

Here we have set up a filter that compares 
two fields Actual and Estimate costs. 

Custom filters can be saved and retrieved 
using the dialog. Here we are using the 
supplied rolling date filters.  
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Manipulating the display

f4b allows you to change how data is displayed within the main grid so that you can more 
easily view the relevant information.

Filters reduce the number of records available to be returned from the database. Returning 
more data than can be read on the screen when looking for information is not recommended 
as it creates unnecessary network traffic for something you are not actually looking at. There 
are a number of tools that help you summarise what you have selected before you, for 
example, send out an Excel report. 

Page Size

By default the f4b page size is 20 records (10 in mobile mode). In practice most PC 
screens can display about 30 records so settings greater than this will result in a scroll bar.
It is generally quicker to use the paging buttons to the right of the page size.

Record Count 
Intuitively this button should move you to the last page, it does not do this but does put the 
record count onto the title bar (moving to the last page is technically simple but involves the 
database server in a great deal of work that slows other users). It is more efficient to sort your
data to see the data required.  

Sorting by one column

Clicking the column header sorts the data, a second click reverses the sort order. Here we 
are sorting by ‘Sales Goods Totals’ in descending order.
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Selecting columns/fields and multiple column sorting 

What fields to display in the main grid is controlled by the Field Selector. Here we are 
showing 12 of the 200 plus fields available in the Jobs View. The fewer columns you select 
the quicker f4b will populate the grid (The Field Selector presents differently when viewing 
summary information like League Tables, Breakdowns and Overviews, see Management 
Reporting section)  

1. To change which columns are displayed, ensure each column that you want to be visible is 
checked and uncheck any that you do not wish to be displayed. TIP - Where, as in this 
case, there are a lot of columns available it is often easier to find columns by sorting on 
Column Name by clicking the 'Column Name' header)

2. To reposition a column(s), do the following. 

 Select the row(s) you want to move.

 Use the controls on the right to move the column to the desired position.

 and  move the selected column(s) up and down one place within the list, 
respectively.

 and  move the selected column(s) to the first/last position within the list, 
respectively.

1. You can set up multicolumn sorting using the combos in the Sort column

You can also set the sort order via right clicking the column headers

2. When you have made your changes, click OK.

This closes the window and refreshes the main data displayed with only your selected 
columns visible and in the order shown in the Field Selector window. 
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Displaying totals 

Once you have the records and fields you are interested in, clicking this button will switch 
on and off the totals line. The Totals displayed in this line are the sum of all the records 
matching your filter rather than the sum of those displayed on the current page. 

Changing the width of columns 

To change the width of a column within the query table:

1. Position the cursor over the right column divider within the row of column headings.

The cursor becomes a double-ended arrow.

2. Click and hold down the left mouse button and drag and drop the column to the desired 
width.  TIP - If you double-click the column divider, the column will automatically resize to 
fit the widest data value in the column.
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Saving your View as a favourite

Once you have set up your view, you can save it as a favourite view for later use.

The view relates to the current tab, so when you save a view as a favourite, it is associated 
with the tab you are viewing at the time. Each tab will have its own list of favourite views.

1. To save your query click Save  on the f4b toolbar

The Save Filter as User View dialog will be displayed. Basic users do not have access to the
SQL and Fields tabs or the menu options.

2. Select whether you want the view to be available for this session only, or permanent. 

3. Give your view a name by entering it in the Tab Name field. View names must be unique. 

4. You can optionally set up conditional formatting from here using the Background, Text and 
Font buttons. If you do this your favourites list will reflect your choices and records 
matching your filter in the main grid will also match your choices irrespective of the 
favourite view you are displaying (conditional formatting can be turned on and off using the

toolbar button ).  

5. Click  and when prompted click Yes to save your view.

Removing a saved view 
Views you own can be deleted via the File menu. Load the view into the main grid then 
File>Delete>User View. If you do not own the view or the view is displayed on opening an 
activity f4b will inform you. 

13



Reports (Basic) 

While you are working on your data, you can view it at any time on screen as a report rather 
than in the Classic (spreadsheet-like) style, as described below. 

Pressing this toolbar button will toggle you between the classic data grid view and the 
report view. In report view mode, ALL the selected data is returned to the f4b application 
then formatted and paginated by the report viewer.

Use the report viewer toolbar to change the display as required. 

This tool bar enables you to print or export to a .PDF file or EXCEL spreadsheet complete 
with the logo and other formatting. You can also email your report from here via the main 

toolbar button 
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Management Reporting

At this time there are four analysis tab types supported by f4b. These tabs are linked tabs that
summarise (aggregate) data from primary/header tabs. As with other linked tabs you can 
carry out further filtering, sort, size fields and report from these tabs. The main difference in 

use is noticed when using the Field Selector 

League tabs

This analysis can be used to display, for instance, market share type statistics. Determined by 
the TOP setting in the field selector (set to 5 here) the chart will rank the records based on the
sort field, of the main grid. Records not in the TOP5 are summed together as a ‘Rest’ segment 

BreakDown tabs

This analysis by default presents the result as a drill down report. The results can also be 

presented in the other available styles by pressing the View Style toolbar button 
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Overview tabs

This analysis gives a basic cross tabulation of 2 columns. This is the simplest form of a Pivot 
Table.

Period Comparison tabs

This analysis enables you to compare the performance of one period versa another of the 
selected Value.

Advanced Reporting
f4b presents reports in place of the main grid using a .NET add on control ‘ReportViewer’. What
the report viewer does is stream the data returned by your Filter/SQL query with an .rdlc 
template, this template is pretty much an XML report template. The .rdlc templates used 
above are all created on the fly and kept in memory by f4b. It is however possible to save 
these templates to external files where they can be edited using Microsoft report design tools 
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such as Visual Studio. In practice any externally edited/created .rdlc can be loaded and run by 
f4b.  

 If you want to start your report design from the automatically generated template, selecting 
File>Report>Save Report Definition As… brings up the dialog as shown. Save and edit 
externally.

Reports can be loaded using File>Reports>Open. To offer your report for running from a 
particular tab/form you will need access to the User Form Actions tab. Find your form then use
Actions>Link Report to Form Action will guide you through populating the record.

Activities 
How much Basic users can do, with respect to activities, depends on privileges set by the 
Administrator. By default they can:-

Reorder tabs 

Tabs can be reordered by selecting the tab then using the Tools>Shift Tab options or by 
dragging and dropping while pointing at a tab name.

Close tabs 
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Tabs can be closed by selecting the tab then using the Close Tab toolbar button.

Select a favourite view as a primary view

The favourite view takes over the linked view filtering

Save an activity with a new name

Use  File>Save Activity  to save the activity.

If the Administrator enables it:-

Add Views to Activities

First select the blank tab at the end of the tab list then use File>Forms  to open a forms tab. 
The views available with your privileges will be displayed. Select the required view and press 
the Open View button (If the button is not visible use the Actions Menu)
.

Create New Activities

In practice the administrator giving you access to the menu File>Forms means you can 
create a new Activity using the methods described above. There is a shortcut to doing this 
however if the administrator provides you with access to the activity <New>. Selecting this 
simply closes all tabs in the tab list and opens the Forms Tab.
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The f4b toolbar

The table below describes the f4b functions available from the toolbar.

Icon Description Command Functionality

Clear Filter Filter>Clear Clears all filters on the current tab.

Update Cache

(or simply 
Refresh Data if
there is no 
Cache)

Actions>Refresh 
name Cache

Obtains current data from the database and 
re-runs your query.

Depending on the size of the system database 
and the complexity of your query, this can 
take a few minutes and unless you believe the 
data to be more than a few minutes old it may
be preferable not to use this function.

Find In Any 
Field

Searches the query table data for the string in 
the adjacent box and returns all records with 
at least one matching field.

The search is not case sensitive (both lower 
and uppercase matches are returned). 
Wildcards are permitted, so a search for LH*E 
for example, would match any number of 
characters between the LH and the E. A search
for L??E would match exactly two characters 
between L and E.

To search for empty fields, enter a space as 
the search string. 

Custom Filter Filter>Custom… Allows you to define a custom filter.

Not (negative 
filter)

Filter>Not Allows you to exclude matching data records 
from the query. 

Home File>Home Activity Returns you to your default activity (the one 
displayed when you first launch f4b). It 
removes any filters you may have set, 
restores any closed tabs and places tabs in the
default order.

Hotel File>Hotel/Last 
Activity

Reloads the current activity. Note that this is 
different from the Home key, which reloads 
your default activity. Hotel removes any filters 
you may have set, restores any closed tabs 
and places tabs in the default order. 

Diary Tools>Diary… Allows user to communicate with each other, 
keeps a record of emails and attachments sent
out via f4b

Field List Tools>Field List… Allows you to select which data fields should 
be included in the query table display and to 
change the position of data columns within the
table.

Document 
Management 

Tools>Document 
Management…

By selecting a record in the main grid 
documents can be attached and viewed

Add to Basket Tools>Add to 
Basket

When set up allows the adding of data from 
selected records into a temporary table for 
editing and further use
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Icon Description Command Functionality

Email Tools>Email Allows you to send or schedule emails from 
the current activity

Close Tab File>Close Tab Closes the current tab. The data remains in 
your query, but is not displayed.

Save Filter As 
User View

File>Save Filter As 
User View… 

Saves the activity and filters on the current 
tab as a favourite query.

Conditional 
Formatting

View>Conditional 
formatting 

Toggles between displaying/hiding any 
conditional formatting

Route Planning Tools>Get Route Enabled when there is routable information on 
the main grid. Fires off your web browser with 
the route from your set location. Can be used 
in conjunction with Add to Basket to get a 
route with vias 

Add Record Edit>New Record On editable data can be used in conjunction 
with the Edit button to add data to the main 
grid. Predefined default values are combined 
with values from the filter line and are 
automatically entered.

Edit Data Edit>Edit Enables/disable editing of data. Depending on 
the edit mode for the current view this button 
will either enable editing on the grid or prompt
you to select a record, after selecting a record 
pressing Edit will open a form for you.

Delete 
Selected Line

Edit>Delete On editable data can be used in conjunction 
with the Edit button to delete data to the main
grid. 

Records/Page Sets how many records are displayed on one 
screen page. 

First/Prev/Next Tools>First Page

Tools>Next Page

Tools>Previous 
Page

Populates the main grid with data records 
determined by Records/Page 

Count Records Tools>Count 
Records

Displays the total number of records in the 
current view after RecordCount = in the title 
bar.

Graphical 
Analysis

View>Graphical 
Analysis 

This button is only enabled for Administrator 
and Developer users. Clicking it while viewing 
a primary/header tab results in new 
management reporting tabs being set up and 
added to the current activity.

View Style View>Style>Simple
Report

View>Style>Classic

Toggles between displaying the Classic View 
and the Report View. On Breakdown analysis 
tabs a breakdown toggle is added

Totals Line View>Totals Line Toggles between displaying/hiding the totals 
line. When displayed, the totals line shows the 
totals of numeric data fields (columns) within 
the query table.
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